summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml11
1 files changed, 6 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b2f5450..1ab542e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,10 +10,10 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
-rust-version = "1.37"
+edition = "2021"
+rust-version = "1.56"
name = "pin-project-internal"
-version = "1.0.12"
+version = "1.1.3"
description = """
Implementation detail of the `pin-project` crate.
"""
@@ -24,6 +24,7 @@ keywords = [
]
categories = [
"no-std",
+ "no-std::no-alloc",
"rust-patterns",
]
license = "Apache-2.0 OR MIT"
@@ -36,13 +37,13 @@ targets = ["x86_64-unknown-linux-gnu"]
proc-macro = true
[dependencies.proc-macro2]
-version = "1"
+version = "1.0.60"
[dependencies.quote]
version = "1"
[dependencies.syn]
-version = "1.0.56"
+version = "2.0.1"
features = [
"full",
"visit-mut",