aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAurélien Zanelli <aurelien.zanelli@darkosphere.fr>2013-05-26 22:08:02 +0200
committerTimothy B. Terriberry <tterribe@xiph.org>2013-05-26 14:01:11 -0700
commitfaec6736cb4dc3d7cd7982f4b72378d5c0ca560c (patch)
tree8c96964c62dfc58dd809b582b9f53dbe0147f6ee /configure.ac
parent319fe445e30eb77ba04f8ac610317417653ddf62 (diff)
downloadlibopus-faec6736cb4dc3d7cd7982f4b72378d5c0ca560c.tar.gz
Add an option to disable build of extra programs (demos and tests)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ce369ddf..87ef2a55 100644
--- a/configure.ac
+++ b/configure.ac
@@ -210,6 +210,14 @@ if test "$HAVE_DOXYGEN" != "yes" -o "$ac_enable_doc" != "yes"; then
fi
AM_CONDITIONAL(HAVE_DOXYGEN, [test $HAVE_DOXYGEN = yes])
+ac_enable_extra_programs="yes"
+AC_ARG_ENABLE([extra-programs],
+ AS_HELP_STRING([--disable-extra-programs], [Do not build extra programs (demo and tests)]),
+ [ac_enable_extra_programs=$enableval])
+if test "$ac_enable_extra_programs" != "yes"; then
+ ac_enable_extra_progs="no"
+fi
+
saved_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS -fvisibility=hidden"
AC_MSG_CHECKING([if ${CC} supports -fvisibility=hidden])
@@ -272,6 +280,7 @@ AC_SUBST(SIZE32)
AM_CONDITIONAL([FIXED_POINT], [test x$ac_enable_fixed = xyes])
AM_CONDITIONAL([CUSTOM_MODES], [test x$ac_enable_custom_modes = xyes])
+AM_CONDITIONAL([EXTRA_PROGRAMS], [test x$ac_enable_extra_programs = xyes])
dnl subsitutions for the pkg-config files
if test x$ac_enable_float = xyes; then
@@ -317,6 +326,7 @@ AC_MSG_RESULT([
Fuzzing: ....................... ${ac_enable_fuzzing}
API documentation: ............. ${ac_enable_doc}
+ Extra programs: ................ ${ac_enable_extra_programs}
------------------------------------------------------------------------
])