aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRon <ron@debian.org>2013-07-02 02:35:53 +0930
committerRon <ron@debian.org>2013-07-02 02:35:53 +0930
commitf92286b3dab0b59c984eb12ce32e7f40da3d671a (patch)
tree8075710b8f6c6d23faf1b0652fb7753192eb28db /configure.ac
parenta9daf9fec3b43573e164e0486b4efca4272934bf (diff)
downloadlibopus-f92286b3dab0b59c984eb12ce32e7f40da3d671a.tar.gz
Get rid of PC_LIBM
It only existed to not include -lm in the .pc for fixed point builds, but that is still needed since the float API is still enabled and will use at least lrint.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 0 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 13d04b09..3881cb4d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -125,7 +125,6 @@ AS_IF([test "$enable_fixed_point" = "yes"],[
],[
enable_float="yes";
PC_BUILD="floating-point"
- PC_LIBM="$LIBM"
])
AM_CONDITIONAL([FIXED_POINT], [test "$enable_fixed_point" = "yes"])
@@ -145,7 +144,6 @@ AC_ARG_ENABLE([custom-modes],
AS_IF([test "$enable_custom_modes" = "yes"],[
AC_DEFINE([CUSTOM_MODES], [1], [Custom modes])
PC_BUILD="$PC_BUILD, custom modes"
- PC_LIBM="$LIBM"
])
AM_CONDITIONAL([CUSTOM_MODES], [test "$enable_custom_modes" = "yes"])
@@ -289,7 +287,6 @@ LIBS="$saved_LIBS"
AC_CHECK_FUNCS([__malloc_hook])
AC_SUBST([PC_BUILD])
-AC_SUBST([PC_LIBM])
AC_CONFIG_FILES([Makefile opus.pc opus-uninstalled.pc