aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJean-Marc Valin <jmvalin@amazon.com>2023-11-27 22:57:32 -0500
committerJean-Marc Valin <jmvalin@amazon.com>2023-11-27 23:08:56 -0500
commitdf637713aac51cb6c14ebfe07fad00819a99401f (patch)
tree91830115e971fe1e036e05e04b4d8bcea1da6c8e /configure.ac
parentc143b72c4c321b5907cbe839079efd3b2455ac9a (diff)
downloadlibopus-df637713aac51cb6c14ebfe07fad00819a99401f.tar.gz
Fixes for ARMv7/AArch32
1) Enable asm/intrinsics even for floating-point 2) Make sure ARMv8 asimd enables EDSP/MEDIA/Neon 3) Add dotp architecture to rtcd table since AArch *can* have dotp
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8cab79b2..b4c5f2a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -220,7 +220,7 @@ AS_IF([test x"${enable_asm}" = x"yes"],[
case $host_cpu in
arm*)
dnl Currently we only have asm for fixed-point
- AS_IF([test "$enable_float" != "yes"],[
+ #AS_IF([test "$enable_float" != "yes"],[
cpu_arm=yes
AC_DEFINE([OPUS_ARM_ASM], [], [Make use of ARM asm optimization])
AS_GCC_INLINE_ASSEMBLY(
@@ -366,7 +366,7 @@ AS_IF([test x"${enable_asm}" = x"yes"],[
[*** ARM assembly requires perl -- disabling optimizations])
asm_optimization="(missing perl dependency for ARM)"
])
- ])
+ #])
;;
esac
],[