aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJean-Marc Valin <jmvalin@jmvalin.ca>2013-11-04 12:26:50 -0500
committerJean-Marc Valin <jmvalin@jmvalin.ca>2013-11-04 12:26:50 -0500
commitd814c5d2832e721d1740631ae41fc4268445b372 (patch)
tree4ea812796ad5dca8a82b7d76f20921e707a12055 /configure.ac
parent8f466274d3bfc1e14503fef02be1a5ffc6ed6d64 (diff)
downloadlibopus-d814c5d2832e721d1740631ae41fc4268445b372.tar.gz
Exposes --disable-float-api in autoconf
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2d4896bd..e511558d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -138,6 +138,17 @@ AS_IF([test "$enable_fixed_point_debug" = "yes"],[
AC_DEFINE([FIXED_DEBUG], [1], [Debug fixed-point implementation])
])
+AC_ARG_ENABLE([float_api],
+ [AS_HELP_STRING([--disable-float-api],
+ [compile without the floating point API (for machines with no float library)])],,
+ [enable_float_api=yes])
+
+AM_CONDITIONAL([DISABLE_FLOAT_API], [test "$enable_float_api" = "no"])
+
+AS_IF([test "$enable_float_api" = "no"],[
+ AC_DEFINE([DISABLE_FLOAT_API], [1], [Do not build the float API])
+])
+
AC_ARG_ENABLE([custom-modes],
[AS_HELP_STRING([--enable-custom-modes], [enable non-Opus modes, e.g. 44.1 kHz & 2^n frames])],,
[enable_custom_modes=no])