aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJean-Marc Valin <jmvalin@amazon.com>2023-12-21 23:36:16 -0500
committerJean-Marc Valin <jmvalin@amazon.com>2023-12-22 03:42:16 -0500
commitbd2e9a34fba837386082e5e16f1b878a16f2274e (patch)
tree421f11c3bf025f1cb532c940e2cc4cfb6466ac60 /configure.ac
parentcaca188b5a0275b1c04baf8fcc9798b900692a2c (diff)
downloadlibopus-bd2e9a34fba837386082e5e16f1b878a16f2274e.tar.gz
Add simulated loss to opus_demo
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 84ce651d..63ae9329 100644
--- a/configure.ac
+++ b/configure.ac
@@ -180,6 +180,15 @@ AS_IF([test "$enable_deep_plc" = "yes" || test "$enable_dred" = "yes" || test "$
])
AM_CONDITIONAL([ENABLE_DEEP_PLC], [test "$enable_deep_plc" = "yes" || test "$enable_dred" = "yes" || test "$enable_osce" = "yes" || test "$enable_osce_training_data" = "yes"])
+AC_ARG_ENABLE([lossgen],
+ [AS_HELP_STRING([--enable-lossgen], [Build opus_demo with packet loss simulator])],,
+ [enable_lossgen=no])
+
+AS_IF([test "$enable_lossgen" = "yes"],[
+ AC_DEFINE([ENABLE_LOSSGEN], [1], [LOSSGEN])
+])
+AM_CONDITIONAL([ENABLE_LOSSGEN], [test "$enable_lossgen" = "yes"])
+
has_float_approx=no
case "$host_cpu" in
i[[3456]]86 | x86_64 | arm* | aarch64* | powerpc64 | powerpc32 | ia64)