aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJean-Marc Valin <jmvalin@amazon.com>2023-10-15 03:39:40 -0400
committerJean-Marc Valin <jmvalin@amazon.com>2023-10-15 03:39:40 -0400
commit6ea9312a93baa663a4695ce89d7d0691a3abb2ce (patch)
tree979d9342445546e2f3bbb3fb0359c578161ef77c /configure.ac
parent9ed3c7c982d58988a891d8b12d79bd234bd0b806 (diff)
downloadlibopus-6ea9312a93baa663a4695ce89d7d0691a3abb2ce.tar.gz
Only compile PLC/DRED conditionally
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0634e6d0..3bb7ed59 100644
--- a/configure.ac
+++ b/configure.ac
@@ -169,6 +169,7 @@ AC_ARG_ENABLE([dred],
AS_IF([test "$enable_dred" = "yes"],[
AC_DEFINE([ENABLE_DRED], [1], [DRED])
])
+AM_CONDITIONAL([ENABLE_DRED], [test "$enable_dred" = "yes"])
AC_ARG_ENABLE([deep-plc],
[AS_HELP_STRING([--enable-deep-plc], [Use deep PLC for SILK])],,
@@ -177,6 +178,7 @@ AC_ARG_ENABLE([deep-plc],
AS_IF([test "$enable_deep_plc" = "yes"],[
AC_DEFINE([ENABLE_DEEP_PLC], [1], [Deep PLC])
])
+AM_CONDITIONAL([ENABLE_DEEP_PLC], [test "$enable_deep_plc" = "yes"])
has_float_approx=no
#case "$host_cpu" in