aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTimothy B. Terriberry <territim@amazon.com>2022-07-06 15:23:12 -0700
committerTimothy B. Terriberry <territim@amazon.com>2022-07-09 21:18:52 -0700
commit08088411259056f63774befb2d00951fdd5c46ba (patch)
treea501ceff6a61d14806d6edc6d38004e96fbeb87d /Makefile.am
parent71fb707875b95672f0cd1cb153c890eff4219720 (diff)
downloadlibopus-08088411259056f63774befb2d00951fdd5c46ba.tar.gz
Only build platform RTCD sources when enabled.
To avoid issues with empty compilation units.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index e1f8c2c4..492fc09d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -36,6 +36,11 @@ else
OPUS_SOURCES += $(OPUS_SOURCES_FLOAT)
endif
+if CPU_X86
+if HAVE_RTCD
+CELT_SOURCES += $(CELT_SOURCES_X86_RTCD)
+SILK_SOURCES += $(SILK_SOURCES_X86_RTCD)
+endif
if HAVE_SSE
CELT_SOURCES += $(CELT_SOURCES_SSE)
endif
@@ -45,10 +50,13 @@ endif
if HAVE_SSE4_1
CELT_SOURCES += $(CELT_SOURCES_SSE4_1)
endif
+endif
if CPU_ARM
-CELT_SOURCES += $(CELT_SOURCES_ARM)
-SILK_SOURCES += $(SILK_SOURCES_ARM)
+if HAVE_RTCD
+CELT_SOURCES += $(CELT_SOURCES_ARM_RTCD)
+SILK_SOURCES += $(SILK_SOURCES_ARM_RTCD)
+endif
if HAVE_ARM_NEON_INTR
CELT_SOURCES += $(CELT_SOURCES_ARM_NEON_INTR)