summaryrefslogtreecommitdiff
path: root/peripheral/libupm/src/t3311/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'peripheral/libupm/src/t3311/CMakeLists.txt')
-rw-r--r--peripheral/libupm/src/t3311/CMakeLists.txt24
1 files changed, 0 insertions, 24 deletions
diff --git a/peripheral/libupm/src/t3311/CMakeLists.txt b/peripheral/libupm/src/t3311/CMakeLists.txt
deleted file mode 100644
index 89bc6b9..0000000
--- a/peripheral/libupm/src/t3311/CMakeLists.txt
+++ /dev/null
@@ -1,24 +0,0 @@
-set (libname "t3311")
-set (libdescription "upm module for the Comet System T3311")
-set (module_src ${libname}.cxx)
-set (module_h ${libname}.h)
-
-pkg_search_module(MODBUS libmodbus)
-if (MODBUS_FOUND)
- set (reqlibname "libmodbus")
- include_directories(${MODBUS_INCLUDE_DIRS})
- upm_module_init()
- add_dependencies(${libname} ${MODBUS_LIBRARIES})
- target_link_libraries(${libname} ${MODBUS_LIBRARIES})
- if (BUILDSWIG)
- if (BUILDSWIGNODE)
- swig_link_libraries (jsupm_${libname} ${MODBUS_LIBRARIES} ${MRAA_LIBRARIES} ${NODE_LIBRARIES})
- endif()
- if (BUILDSWIGPYTHON)
- swig_link_libraries (pyupm_${libname} ${MODBUS_LIBRARIES} ${PYTHON_LIBRARIES} ${MRAA_LIBRARIES})
- endif()
- if (BUILDSWIGJAVA)
- swig_link_libraries (javaupm_${libname} ${MODBUS_LIBRARIES} ${MRAAJAVA_LDFLAGS} ${JAVA_LDFLAGS})
- endif()
- endif()
-endif ()