summaryrefslogtreecommitdiff
path: root/peripheral/libupm/src/ozw/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'peripheral/libupm/src/ozw/CMakeLists.txt')
-rw-r--r--peripheral/libupm/src/ozw/CMakeLists.txt21
1 files changed, 0 insertions, 21 deletions
diff --git a/peripheral/libupm/src/ozw/CMakeLists.txt b/peripheral/libupm/src/ozw/CMakeLists.txt
deleted file mode 100644
index 6c67157..0000000
--- a/peripheral/libupm/src/ozw/CMakeLists.txt
+++ /dev/null
@@ -1,21 +0,0 @@
-set (libname "ozw")
-set (libdescription "upm module for the OpenZWave library interface")
-set (module_src ${libname}.cxx zwNode.cxx)
-set (module_h ${libname}.h)
-
-pkg_search_module(OPENZWAVE libopenzwave)
-if (OPENZWAVE_FOUND)
- set (reqlibname "libopenzwave")
- include_directories(${OPENZWAVE_INCLUDE_DIRS})
- upm_module_init()
- add_dependencies(${libname} ${OPENZWAVE_LIBRARIES})
- target_link_libraries(${libname} ${OPENZWAVE_LIBRARIES})
- if (BUILDSWIG)
- if (BUILDSWIGNODE)
- swig_link_libraries (jsupm_${libname} ${OPENZWAVE_LIBRARIES} ${MRAA_LIBRARIES} ${NODE_LIBRARIES})
- endif()
- if (BUILDSWIGPYTHON)
- swig_link_libraries (pyupm_${libname} ${OPENZWAVE_LIBRARIES} ${PYTHON_LIBRARIES} ${MRAA_LIBRARIES})
- endif()
- endif()
-endif ()