summaryrefslogtreecommitdiff
path: root/peripheral/libupm/src/bmi160/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'peripheral/libupm/src/bmi160/CMakeLists.txt')
-rw-r--r--peripheral/libupm/src/bmi160/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/peripheral/libupm/src/bmi160/CMakeLists.txt b/peripheral/libupm/src/bmi160/CMakeLists.txt
new file mode 100644
index 0000000..4286851
--- /dev/null
+++ b/peripheral/libupm/src/bmi160/CMakeLists.txt
@@ -0,0 +1,5 @@
+set (libname "bmi160")
+set (libdescription "Bosch BMI160 Accelerometer, Gyroscope and BMM150 Magnetometer")
+set (module_src ${libname}.cxx bosch_bmi160.c)
+set (module_hpp ${libname}.hpp)
+upm_module_init()