aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build24
1 files changed, 2 insertions, 22 deletions
diff --git a/meson.build b/meson.build
index 3546c15..b8b41fe 100644
--- a/meson.build
+++ b/meson.build
@@ -22,7 +22,7 @@
project(
'tinyxml2',
['cpp'],
- version : '9.0.0',
+ version : '10.0.0',
meson_version : '>= 0.49.0',
)
@@ -62,26 +62,6 @@ if meson.version().version_compare('>= 0.54.0')
endif
if get_option('tests')
- # Try to find a copy command. If this is windows we probably don't have cp,
- # but if this is msys then we do, so make cp not required in that case, and
- # try Xcopy if cp isn't found
- prog_cp = find_program('cp', required : build_machine.system() != 'windows')
- command = ['-r']
- if not prog_cp.found()
- prog_cp = find_program('Xcopy')
- command = ['/E', '/I']
- endif
-
- # Copy the test resources into the build dir
- run_command(
- prog_cp,
- [
- command,
- meson.current_source_dir() / 'resources',
- meson.current_build_dir(),
- ],
- )
-
test(
'xmltest',
executable(
@@ -89,7 +69,7 @@ if get_option('tests')
['xmltest.cpp'],
link_with : [lib_tinyxml2],
),
- workdir : meson.current_build_dir(),
+ workdir : meson.current_source_dir(),
)
endif