aboutsummaryrefslogtreecommitdiff
path: root/gen/build/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'gen/build/Cargo.toml')
-rw-r--r--gen/build/Cargo.toml19
1 files changed, 10 insertions, 9 deletions
diff --git a/gen/build/Cargo.toml b/gen/build/Cargo.toml
index 9b74255b..ee20e2b7 100644
--- a/gen/build/Cargo.toml
+++ b/gen/build/Cargo.toml
@@ -1,11 +1,11 @@
[package]
name = "cxx-build"
-version = "1.0.93"
+version = "1.0.119"
authors = ["David Tolnay <dtolnay@gmail.com>"]
categories = ["development-tools::build-utils", "development-tools::ffi"]
description = "C++ code generator for integrating `cxx` crate into a Cargo build."
documentation = "https://docs.rs/cxx-build"
-edition = "2018"
+edition = "2021"
exclude = ["build.rs"]
homepage = "https://cxx.rs"
keywords = ["ffi", "build-dependencies"]
@@ -19,21 +19,22 @@ parallel = ["cc/parallel"]
experimental-async-fn = []
[dependencies]
-cc = "1.0.49"
+cc = "1.0.83"
codespan-reporting = "0.11.1"
-once_cell = "1.9"
-proc-macro2 = { version = "1.0.39", default-features = false, features = ["span-locations"] }
-quote = { version = "1.0", default-features = false }
-scratch = "1.0"
-syn = { version = "2.0.1", default-features = false, features = ["parsing", "printing", "clone-impls", "full"] }
+once_cell = "1.18"
+proc-macro2 = { version = "1.0.74", default-features = false, features = ["span-locations"] }
+quote = { version = "1.0.35", default-features = false }
+scratch = "1.0.5"
+syn = { version = "2.0.46", default-features = false, features = ["clone-impls", "full", "parsing", "printing"] }
[dev-dependencies]
cxx = { version = "1.0", path = "../.." }
cxx-gen = { version = "0.7", path = "../lib" }
-pkg-config = "0.3"
+pkg-config = "0.3.27"
[lib]
doc-scrape-examples = false
[package.metadata.docs.rs]
targets = ["x86_64-unknown-linux-gnu"]
+rustdoc-args = ["--generate-link-to-definition"]