aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 10 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9ad85ba..5a34ad6 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,14 +10,14 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
-rust-version = "1.37"
+edition = "2021"
+rust-version = "1.56"
name = "pin-project"
-version = "1.0.12"
+version = "1.1.3"
exclude = [
"/.*",
- "/ci",
"/tools",
+ "/DEVELOPMENT.md",
]
description = """
A crate for safe and ergonomic pin-projection.
@@ -30,6 +30,7 @@ keywords = [
]
categories = [
"no-std",
+ "no-std::no-alloc",
"rust-patterns",
]
license = "Apache-2.0 OR MIT"
@@ -38,8 +39,11 @@ repository = "https://github.com/taiki-e/pin-project"
[package.metadata.docs.rs]
targets = ["x86_64-unknown-linux-gnu"]
+[lib]
+doc-scrape-examples = false
+
[dependencies.pin-project-internal]
-version = "=1.0.12"
+version = "=1.1.3"
[dev-dependencies.macrotest]
version = "1.0.9"
@@ -51,4 +55,4 @@ version = "1"
version = "1"
[dev-dependencies.trybuild]
-version = "1.0.49"
+version = "1.0.67"