aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml60
1 files changed, 45 insertions, 15 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e739019..9e95051 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,31 +10,55 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
+edition = "2021"
+rust-version = "1.61"
name = "memchr"
-version = "2.4.1"
-authors = ["Andrew Gallant <jamslam@gmail.com>", "bluss"]
-exclude = ["/bench", "/.github", "/fuzz"]
-description = "Safe interface to memchr."
+version = "2.7.1"
+authors = [
+ "Andrew Gallant <jamslam@gmail.com>",
+ "bluss",
+]
+exclude = [
+ "/.github",
+ "/benchmarks",
+ "/fuzz",
+ "/scripts",
+ "/tmp",
+]
+description = """
+Provides extremely fast (uses SIMD on x86_64, aarch64 and wasm32) routines for
+1, 2 or 3 byte search and single substring search.
+"""
homepage = "https://github.com/BurntSushi/memchr"
documentation = "https://docs.rs/memchr/"
readme = "README.md"
-keywords = ["memchr", "char", "scan", "strchr", "string"]
-license = "Unlicense/MIT"
+keywords = [
+ "memchr",
+ "memmem",
+ "substring",
+ "find",
+ "search",
+]
+license = "Unlicense OR MIT"
repository = "https://github.com/BurntSushi/memchr"
+
+[package.metadata.docs.rs]
+rustdoc-args = ["--generate-link-to-definition"]
+
[profile.bench]
-debug = true
+debug = 2
[profile.release]
-debug = true
+debug = 2
[profile.test]
opt-level = 3
-debug = true
+debug = 2
[lib]
name = "memchr"
bench = false
+
[dependencies.compiler_builtins]
version = "0.1.2"
optional = true
@@ -44,16 +68,22 @@ version = "1.0.0"
optional = true
package = "rustc-std-workspace-core"
-[dependencies.libc]
-version = "0.2.18"
+[dependencies.log]
+version = "0.4.20"
optional = true
-default-features = false
+
[dev-dependencies.quickcheck]
version = "1.0.3"
default-features = false
[features]
+alloc = []
default = ["std"]
-rustc-dep-of-std = ["core", "compiler_builtins"]
-std = []
+libc = []
+logging = ["dep:log"]
+rustc-dep-of-std = [
+ "core",
+ "compiler_builtins",
+]
+std = ["alloc"]
use_std = ["std"]