aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml51
1 files changed, 37 insertions, 14 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9ae35a0..32e9a99 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,46 +3,69 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
+edition = "2021"
name = "anes"
-version = "0.1.6"
-authors = ["Robert Vojta <rvojta@me.com>"]
-exclude = ["target", "Cargo.lock"]
+version = "0.2.0"
+authors = [
+ "Robert Vojta <rvojta@me.com>",
+ "Andrew Walbran <qwandor@google.com>",
+]
+exclude = [
+ "target",
+ "Cargo.lock",
+]
description = "ANSI Escape Sequences provider & parser"
documentation = "https://docs.rs/anes/"
readme = "README.md"
-keywords = ["terminal", "ansi", "sequence", "code", "parser"]
+keywords = [
+ "terminal",
+ "ansi",
+ "sequence",
+ "code",
+ "parser",
+]
+categories = [
+ "command-line-interface",
+ "parser-implementations",
+]
license = "MIT OR Apache-2.0"
-repository = "https://github.com/zrzka/anes-rs"
+repository = "https://github.com/qwandor/anes-rs"
+
[package.metadata.docs.rs]
all-features = true
[lib]
bench = false
+[[example]]
+name = "parser"
+required-features = ["parser"]
+
[[bench]]
name = "bench_main"
harness = false
required-features = ["parser"]
+
[dependencies.bitflags]
-version = "1.2"
+version = "2.4.1"
optional = true
+
[dev-dependencies.criterion]
-version = "0.3"
+version = "0.5.1"
[dev-dependencies.libc]
-version = "0.2.66"
+version = "0.2.150"
[features]
default = []
parser = ["bitflags"]
+
[badges.maintenance]
status = "actively-developed"