summaryrefslogtreecommitdiff
path: root/libdaemon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libdaemon/Makefile.am')
-rw-r--r--libdaemon/Makefile.am47
1 files changed, 0 insertions, 47 deletions
diff --git a/libdaemon/Makefile.am b/libdaemon/Makefile.am
deleted file mode 100644
index 9c56611..0000000
--- a/libdaemon/Makefile.am
+++ /dev/null
@@ -1,47 +0,0 @@
-# This file is part of libdaemon.
-#
-# Copyright 2003-2008 Lennart Poettering
-#
-# Permission is hereby granted, free of charge, to any person obtaining a copy
-# of this software and associated documentation files (the "Software"), to deal
-# in the Software without restriction, including without limitation the rights
-# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-# copies of the Software, and to permit persons to whom the Software is
-# furnished to do so, subject to the following conditions:
-#
-# The above copyright notice and this permission notice shall be included in
-# all copies or substantial portions of the Software.
-#
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-# SOFTWARE.
-#
-
-AM_CPPFLAGS='-DLOCALSTATEDIR="$(localstatedir)"'
-
-pkginclude_HEADERS = \
- dlog.h \
- dfork.h \
- dsignal.h \
- dnonblock.h \
- dpid.h \
- dexec.h \
- daemon.h
-
-lib_LTLIBRARIES = libdaemon.la
-
-libdaemon_la_SOURCES = \
- dlog.c \
- dfork.c \
- dsignal.c \
- dnonblock.c \
- dpid.c \
- dexec.c \
- daemon.h \
- $(pkg_include_HEADERS)
-
-libdaemon_la_LDFLAGS = -version-info $(LIBDAEMON_VERSION_INFO) $(LDFLAGS_NOUNDEFINED)