summaryrefslogtreecommitdiff
path: root/Android.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Android.mk')
-rw-r--r--Android.mk46
1 files changed, 45 insertions, 1 deletions
diff --git a/Android.mk b/Android.mk
index b3f463f..7d49ce3 100644
--- a/Android.mk
+++ b/Android.mk
@@ -21,9 +21,53 @@ TARGET_OUT_COMMON_GENTOO := $(TARGET_OUT_COMMON_INTERMEDIATES)/gentoo
3RD_PARTY_WRAPPERS :=
include $(call all-subdir-makefiles)
+# Some libraries are available in external/ already.
+# Note: Keep this in sync with gentoo/integration/portage/package.provided.in.
+# We do not list packages that do not provide libs/headers.
+3RD_PARTY_EXTERNAL_LIBS := \
+ libavahi-client libavahi-common libavahi-core \
+ libbz \
+ libcrypto libssl \
+ libcares \
+ libcurl \
+ libdbus \
+ libext2_blkid libext2_com_err libext2_e2p libext2fs libext2_quota libext2_uuid libtune2fs \
+ libdw libdwelf libdwfl libebl libelf \
+ libexpat \
+ libFLAC \
+ libgmock \
+ libgtest \
+ libicui18n libicuuc \
+ libiprouteutil libnetlink \
+ libip4tc libip6tc libxtables \
+ libjemalloc \
+ libjpeg \
+ libcap \
+ libcap-ng \
+ libdaemon \
+ libdivsufsort libdivsufsort64 \
+ libevent \
+ libmicrohttpd \
+ libnl \
+ libogg \
+ libopus \
+ libselinux \
+ libunwind \
+ libvpx libwebm \
+ libpcre libpcrecpp \
+ libsepol \
+ libspeex \
+ libtinyxml \
+ libtinyxml2 \
+ libwpa_client \
+ libz \
+ $(NULL)
+# Only depend on the packages that are actually requested.
+3RD_PARTY_EXTERNAL_DEPS += $(filter $(3RD_PARTY_EXTERNAL_LIBS),$(product_MODULES) $(PRODUCT_PACKAGES))
+
# Actually run the emerge command for the specific package.
%.emerge: TARGET_TO_ATOM = $(notdir $(patsubst %/,%,$(dir $(1))))/$(notdir $(1:.emerge=))
-%.emerge: | $(3RD_PARTY_WRAPPERS) $(3RD_PARTY_CONFIGS)
+%.emerge: | $(3RD_PARTY_WRAPPERS) $(3RD_PARTY_CONFIGS) $(3RD_PARTY_EXTERNAL_DEPS)
$(hide)mkdir -p $(dir $@) $(TARGET_OUT_GENTOO)/tmp
$(hide)emerge $(call TARGET_TO_ATOM,$@)
$(hide)3rd-party-merge \