aboutsummaryrefslogtreecommitdiff
path: root/libyasm/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libyasm/CMakeLists.txt')
-rw-r--r--libyasm/CMakeLists.txt72
1 files changed, 37 insertions, 35 deletions
diff --git a/libyasm/CMakeLists.txt b/libyasm/CMakeLists.txt
index f04673c..19c2a01 100644
--- a/libyasm/CMakeLists.txt
+++ b/libyasm/CMakeLists.txt
@@ -42,39 +42,41 @@ ELSE(BUILD_SHARED_LIBS)
)
ENDIF(BUILD_SHARED_LIBS)
-INSTALL(TARGETS libyasm
- RUNTIME DESTINATION bin
- LIBRARY DESTINATION lib
- ARCHIVE DESTINATION lib
- )
+IF (YASM_INSTALL)
+ INSTALL(TARGETS libyasm
+ RUNTIME DESTINATION bin
+ LIBRARY DESTINATION lib
+ ARCHIVE DESTINATION lib
+ )
-INSTALL(FILES
- arch.h
- assocdat.h
- bitvect.h
- bytecode.h
- compat-queue.h
- coretype.h
- dbgfmt.h
- errwarn.h
- expr.h
- file.h
- floatnum.h
- hamt.h
- insn.h
- intnum.h
- inttree.h
- linemap.h
- listfmt.h
- md5.h
- module.h
- objfmt.h
- parser.h
- phash.h
- preproc.h
- section.h
- symrec.h
- valparam.h
- value.h
- DESTINATION include/libyasm
- )
+ INSTALL(FILES
+ arch.h
+ assocdat.h
+ bitvect.h
+ bytecode.h
+ compat-queue.h
+ coretype.h
+ dbgfmt.h
+ errwarn.h
+ expr.h
+ file.h
+ floatnum.h
+ hamt.h
+ insn.h
+ intnum.h
+ inttree.h
+ linemap.h
+ listfmt.h
+ md5.h
+ module.h
+ objfmt.h
+ parser.h
+ phash.h
+ preproc.h
+ section.h
+ symrec.h
+ valparam.h
+ value.h
+ DESTINATION include/libyasm
+ )
+ENDIf()