aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 12 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 82f6c53..d58c7f3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,9 +4,14 @@ if (COMMAND cmake_policy)
cmake_policy(SET CMP0003 NEW)
endif (COMMAND cmake_policy)
+
+# Clear out C Flags for this project, as our parent project has
+# settings that will cause a lot of issues
+SET(CMAKE_C_FLAGS "-O2")
OPTION(BUILD_SHARED_LIBS "Build shared libraries" OFF)
OPTION(ENABLE_NLS "Enable message translations" OFF)
-OPTION(YASM_BUILD_TESTS "Enable building of tests" OFF)
+OPTION(YASM_BUILD_TESTS "Enable building of tests" ON)
+OPTION(YASM_INSTALL "Enable install" OFF)
IF(YASM_BUILD_TESTS)
ENABLE_TESTING()
@@ -38,8 +43,10 @@ ADD_SUBDIRECTORY(libyasm)
ADD_SUBDIRECTORY(modules)
ADD_SUBDIRECTORY(frontends)
-INSTALL(FILES
- libyasm.h
- ${CMAKE_BINARY_DIR}/libyasm-stdint.h
- DESTINATION include
+if (YASM_INSTALL)
+ INSTALL(FILES
+ libyasm.h
+ ${CMAKE_BINARY_DIR}/libyasm-stdint.h
+ DESTINATION include
)
+endif()