aboutsummaryrefslogtreecommitdiff
path: root/test_conformance/gles/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test_conformance/gles/CMakeLists.txt')
-rw-r--r--test_conformance/gles/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/test_conformance/gles/CMakeLists.txt b/test_conformance/gles/CMakeLists.txt
index c76fe512..4f4ba532 100644
--- a/test_conformance/gles/CMakeLists.txt
+++ b/test_conformance/gles/CMakeLists.txt
@@ -18,3 +18,11 @@ set (${MODULE_NAME}_SOURCES
list(APPEND CLConform_LIBRARIES EGL GLESv2)
include(../CMakeCommon.txt)
+
+if(DEFINED USE_GLES3)
+ target_compile_definitions(${${MODULE_NAME}_OUT} PRIVATE GLES3)
+endif()
+if(MSVC)
+ # Don't warn about using the portable "strdup" function.
+ target_compile_definitions(${${MODULE_NAME}_OUT} PRIVATE _CRT_NONSTDC_NO_DEPRECATE)
+endif() \ No newline at end of file