aboutsummaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 9f39d4a5..f04c7778 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -8,11 +8,15 @@ libsgutils2_la_SOURCES = \
sg_pt_common.c
if OS_LINUX
+if PT_DUMMY
+libsgutils2_la_SOURCES += sg_pt_dummy.c
+else
libsgutils2_la_SOURCES += \
sg_pt_linux.c \
sg_io_linux.c \
sg_pt_linux_nvme.c
endif
+endif
if OS_WIN32_MINGW
libsgutils2_la_SOURCES += sg_pt_win32.c
@@ -23,8 +27,12 @@ libsgutils2_la_SOURCES += sg_pt_win32.c
endif
if OS_FREEBSD
+if PT_DUMMY
+libsgutils2_la_SOURCES += sg_pt_dummy.c
+else
libsgutils2_la_SOURCES += sg_pt_freebsd.c
endif
+endif
if OS_SOLARIS
libsgutils2_la_SOURCES += sg_pt_solaris.c
@@ -34,6 +42,14 @@ if OS_OSF
libsgutils2_la_SOURCES += sg_pt_osf1.c
endif
+if OS_NETBSD
+libsgutils2_la_SOURCES += sg_pt_dummy.c
+endif
+
+if OS_OPENBSD
+libsgutils2_la_SOURCES += sg_pt_dummy.c
+endif
+
if DEBUG
# This is active if --enable-debug given to ./configure
# removed -Wduplicated-branches because needs gcc-8