aboutsummaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index f04c7778..97410dc3 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -42,6 +42,14 @@ if OS_OSF
libsgutils2_la_SOURCES += sg_pt_osf1.c
endif
+if OS_HAIKU
+if PT_DUMMY
+libsgutils2_la_SOURCES += sg_pt_dummy.c
+else
+libsgutils2_la_SOURCES += sg_pt_haiku.c
+endif
+endif
+
if OS_NETBSD
libsgutils2_la_SOURCES += sg_pt_dummy.c
endif
@@ -50,6 +58,10 @@ if OS_OPENBSD
libsgutils2_la_SOURCES += sg_pt_dummy.c
endif
+if OS_OTHER
+libsgutils2_la_SOURCES += sg_pt_dummy.c
+endif
+
if DEBUG
# This is active if --enable-debug given to ./configure
# removed -Wduplicated-branches because needs gcc-8