aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 7 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 52d66a97..b873367b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,9 +7,9 @@
# package.
# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+# export DH_VERBOSE=1
-# This is the debhelper compatability version to use.
+# Debhelper compatibility level
export DH_COMPAT=4
configure: configure-stamp
@@ -30,11 +30,12 @@ build-stamp:
clean:
dh_testdir
dh_testroot
- rm -f build-stamp configure-stamp
# Add here commands to clean up after the build process.
-$(MAKE) clean
+ rm -f build-stamp configure-stamp debian/substvars
+
dh_clean
install: DH_OPTIONS=
@@ -47,6 +48,7 @@ install: build
# Add here commands to install the package into debian/tmp
$(MAKE) -e install DESTDIR=$(CURDIR)/debian/tmp PREFIX=/usr
+ find debian/tmp/usr/bin debian/tmp/usr/lib -type f -exec chrpath -d {} \;
dh_install --autodest --sourcedir=debian/tmp
dh_installman
@@ -67,8 +69,9 @@ binary-arch: build install
dh_link -a
dh_compress -a -X archive -X .c -X .h
dh_fixperms -a
+ dh_makeshlibs -V -v
dh_installdeb -a
- dh_shlibdeps -a
+ dh_shlibdeps -ldebian/tmp/usr/lib -L libsgutils1
dh_gencontrol -a
dh_md5sums -a
dh_builddeb -a