aboutsummaryrefslogtreecommitdiff
path: root/build_debian.sh
diff options
context:
space:
mode:
Diffstat (limited to 'build_debian.sh')
-rwxr-xr-xbuild_debian.sh12
1 files changed, 12 insertions, 0 deletions
diff --git a/build_debian.sh b/build_debian.sh
new file mode 100755
index 00000000..7e815175
--- /dev/null
+++ b/build_debian.sh
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+echo "chmod +x debian/rules"
+chmod +x debian/rules
+
+# in some environments the '-rfakeroot' can cause a failure (e.g. when
+# building as root). If so, remove that argument from the following:
+echo "dpkg-buildpackage -b -rfakeroot"
+dpkg-buildpackage -b -rfakeroot
+
+# If the above succeeds then the ".deb" binary package is placed in the
+# parent directory.