aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDouglas Gilbert <dgilbert@interlog.com>2009-09-19 22:48:01 +0000
committerDouglas Gilbert <dgilbert@interlog.com>2009-09-19 22:48:01 +0000
commit4edce602a56c510b39e80642a29153d13e8acfd4 (patch)
treed27e1f599cde3671cf65ac34c86526e30068151c /src/Makefile.am
parent9e11e00479a4cd919028ecf226856e4c78c87354 (diff)
downloadsg3_utils-4edce602a56c510b39e80642a29153d13e8acfd4.tar.gz
testing sg_get_lba_status
git-svn-id: https://svn.bingwo.ca/repos/sg3_utils/trunk@301 6180dd3e-e324-4e3e-922d-17de1ae2f315
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am17
1 files changed, 10 insertions, 7 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1de843aa..643acd65 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -8,8 +8,8 @@ if OS_LINUX
# sg_scan is shared by Linux and Win32
bin_PROGRAMS = \
- sg_dd sg_emc_trespass sg_format sg_get_config sg_ident \
- sginfo sg_inq sg_logs sg_luns sg_map26 sg_map \
+ sg_dd sg_emc_trespass sg_format sg_get_config sg_get_lba_status \
+ sg_ident sginfo sg_inq sg_logs sg_luns sg_map26 sg_map \
sgm_dd sg_modes sg_opcodes sgp_dd sg_persist \
sg_prevent sg_raw sg_rbuf sg_rdac sg_read sg_readcap \
sg_read_block_limits sg_read_buffer sg_read_long sg_reassign \
@@ -30,7 +30,7 @@ endif
if OS_WIN32_MINGW
bin_PROGRAMS = \
- sg_format sg_get_config sg_ident \
+ sg_format sg_get_config sg_get_lba_status sg_ident \
sg_inq sg_logs sg_luns \
sg_modes sg_opcodes sg_persist \
sg_prevent sg_raw sg_rdac sg_readcap sg_read_block_limits \
@@ -52,7 +52,7 @@ endif
if OS_WIN32_CYGWIN
bin_PROGRAMS = \
- sg_format sg_get_config sg_ident \
+ sg_format sg_get_config sg_get_lba_status sg_ident \
sg_inq sg_logs sg_luns \
sg_modes sg_opcodes sg_persist \
sg_prevent sg_raw sg_rdac sg_readcap sg_read_block_limits \
@@ -74,7 +74,7 @@ endif
if OS_FREEBSD
bin_PROGRAMS = \
- sg_format sg_get_config sg_ident \
+ sg_format sg_get_config sg_get_lba_status sg_ident \
sg_inq sg_logs sg_luns \
sg_modes sg_opcodes sg_persist \
sg_prevent sg_raw sg_rdac sg_readcap sg_read_block_limits \
@@ -90,7 +90,7 @@ endif
if OS_SOLARIS
bin_PROGRAMS = \
- sg_format sg_get_config sg_ident \
+ sg_format sg_get_config sg_get_lba_status sg_ident \
sg_inq sg_logs sg_luns \
sg_modes sg_opcodes sg_persist \
sg_prevent sg_raw sg_rdac sg_readcap sg_read_block_limits \
@@ -106,7 +106,7 @@ endif
if OS_OSF
bin_PROGRAMS = \
- sg_format sg_get_config sg_ident \
+ sg_format sg_get_config sg_get_lba_status sg_ident \
sg_inq sg_logs sg_luns \
sg_modes sg_opcodes sg_persist \
sg_prevent sg_raw sg_rdac sg_readcap sg_read_block_limits \
@@ -134,6 +134,9 @@ sg_format_LDADD = ../lib/libsgutils2.la @os_libs@
sg_get_config_SOURCES = sg_get_config.c
sg_get_config_LDADD = ../lib/libsgutils2.la @os_libs@
+sg_get_lba_status_SOURCES = sg_get_lba_status.c
+sg_get_lba_status_LDADD = ../lib/libsgutils2.la @os_libs@
+
sg_ident_SOURCES = sg_ident.c
sg_ident_LDADD = ../lib/libsgutils2.la @os_libs@