aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDouglas Gilbert <dgilbert@interlog.com>2017-10-10 00:46:34 +0000
committerDouglas Gilbert <dgilbert@interlog.com>2017-10-10 00:46:34 +0000
commit2715125260da177d9869321027ef22a9f49fde1b (patch)
tree8825f082ae11e3d47d77db45fd6baa0d4db471c2 /src/Makefile.am
parentb2e59f46a39f19ffc18be02fad71df68974a8d0b (diff)
downloadsg3_utils-2715125260da177d9869321027ef22a9f49fde1b.tar.gz
switch Makefile.am from clang++ but to normal C (gcc)
git-svn-id: https://svn.bingwo.ca/repos/sg3_utils/trunk@720 6180dd3e-e324-4e3e-922d-17de1ae2f315
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f557df05..1012a78d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -37,15 +37,15 @@ endif
## CC = gcc
## CC = g++
## CC = clang
-CC = clang++
+## CC = clang++
# -std=<s> can be c99, c11, gnu11, etc. Default is gnu89 (gnu90 is the same)
# -Wall is no longer all warnings. Add -W (since renamed to -Wextra) for more
AM_CPPFLAGS = -iquote ${top_srcdir}/include -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
-##AM_CFLAGS = -Wall -W @os_cflags@
+AM_CFLAGS = -Wall -W @os_cflags@
# AM_CFLAGS = -Wall -W @os_cflags@ -pedantic -std=c11
# AM_CFLAGS = -Wall -W @os_cflags@ -pedantic -std=c11 --analyze
-AM_CFLAGS = -Wall -W @os_cflags@ -pedantic -std=c++14
+# AM_CFLAGS = -Wall -W @os_cflags@ -pedantic -std=c++14
sg_bg_ctl_LDADD = ../lib/libsgutils2.la @os_libs@