aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDouglas Gilbert <dgilbert@interlog.com>2018-02-05 23:31:17 +0000
committerDouglas Gilbert <dgilbert@interlog.com>2018-02-05 23:31:17 +0000
commit792b75e01390e59708874f41cb189ecb590ebbdb (patch)
treec4dd80978af62f7b56b21548eeba1cafee2185a4 /configure.ac
parent9fe92189ee2e0769daaefccf68d3fabff62b4f6b (diff)
downloadsg3_utils-792b75e01390e59708874f41cb189ecb590ebbdb.tar.gz
Info section added to end of ./configure; sg_persist: add --maxlen=LEN option; sg_opcodes: report when --no-inquiry ignored
git-svn-id: https://svn.bingwo.ca/repos/sg3_utils/trunk@750 6180dd3e-e324-4e3e-922d-17de1ae2f315
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 38 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 66b3bda3..f57720b5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -115,3 +115,41 @@ AC_ARG_ENABLE([nvme-supp],
[AC_DEFINE_UNQUOTED(IGNORE_NVME, 1, [compile out NVMe support], )], [])
AC_OUTPUT(Makefile include/Makefile lib/Makefile src/Makefile doc/Makefile scripts/Makefile)
+
+
+# Borrowed from smartmontools configure.ac
+# Note: Use `...` here as some shells do not properly parse '$(... case $x in X) ...)'
+info=`
+ echo "-----------------------------------------------------------------------------"
+ echo "${PACKAGE}-${VERSION} configuration:"
+ echo "host operating system: $host"
+ echo "C++ compiler: $CXX"
+ echo "C compiler: $CC"
+ echo "preprocessor flags: $CPPFLAGS"
+ echo "C++ compiler flags: $CXXFLAGS"
+ echo "C compiler flags: $CFLAGS"
+ echo "linker flags: $LDFLAGS"
+ echo "OS specific modules: $os_deps $os_libs $LIBS"
+
+ case "$host_os" in
+ mingw*)
+ echo "application manifest: ${os_win32_manifest:-built-in}"
+ echo "resource compiler: $WINDRES"
+ echo "message compiler: $WINDMC"
+ echo "NSIS compiler: $MAKENSIS"
+ ;;
+
+ *)
+ echo "binary install path: \`eval eval eval echo $bindir\`"
+ echo "man page install path: \`eval eval eval echo $mandir\`"
+ echo "doc file install path: \`eval eval eval echo $docdir\`"
+ echo "examples install path: \`eval eval eval echo $exampledir\`"
+ ;;
+ esac
+ echo "-----------------------------------------------------------------------------"
+`
+
+AC_MSG_NOTICE([
+$info
+])
+