aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDouglas Gilbert <dgilbert@interlog.com>2018-03-16 09:38:38 +0000
committerDouglas Gilbert <dgilbert@interlog.com>2018-03-16 09:38:38 +0000
commit760a4bdf5dd5679cf17b4eacf8c5e178cec30839 (patch)
treeb98920b0811b6463becf292ceeb6c8a1f24e7b4a /configure.ac
parent01a31912491efa232e08f71057edb258986b5508 (diff)
downloadsg3_utils-760a4bdf5dd5679cf17b4eacf8c5e178cec30839.tar.gz
Add little/big endian specializations to sg_unaligned.h
git-svn-id: https://svn.bingwo.ca/repos/sg3_utils/trunk@762 6180dd3e-e324-4e3e-922d-17de1ae2f315
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 354a0220..757a2c15 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,6 +16,7 @@ AC_PROG_LIBTOOL
# check for headers
AC_HEADER_STDC
+AC_CHECK_HEADERS([byteswap.h], [], [], [])
# check for functions
AC_CHECK_FUNCS(getopt_long,
@@ -114,6 +115,10 @@ AC_ARG_ENABLE([nvme-supp],
AC_HELP_STRING([--disable-nvme-supp], [remove all or most NVMe code]),
[AC_DEFINE_UNQUOTED(IGNORE_NVME, 1, [compile out NVMe support], )], [])
+AC_ARG_ENABLE([fast-lebe],
+ AC_HELP_STRING([--disable-fast-lebe], [use generic little-endian/big-endian code instead]),
+ [AC_DEFINE_UNQUOTED(IGNORE_FAST_LEBE, 1, [use generic little-endian/big-endian instead], )], [])
+
AC_OUTPUT(Makefile include/Makefile lib/Makefile src/Makefile doc/Makefile scripts/Makefile)