aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDouglas Gilbert <dgilbert@interlog.com>2021-09-12 18:12:47 +0000
committerDouglas Gilbert <dgilbert@interlog.com>2021-09-12 18:12:47 +0000
commit6aa4d33cce95c534665f3f8e057f13a69ab10835 (patch)
treecfb6f1e6a17b8751adf037ab86a1e50594e79fb4 /configure.ac
parent15a477c9f6730cd98e40bbdbb0511cdf3a3c4319 (diff)
downloadsg3_utils-6aa4d33cce95c534665f3f8e057f13a69ab10835.tar.gz
sg_dd: srand48_r() and mrand48_r() are GNU libc specific, put conditional in so non-reentrant version used otherwise
git-svn-id: https://svn.bingwo.ca/repos/sg3_utils/trunk@913 6180dd3e-e324-4e3e-922d-17de1ae2f315
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b00d167f..f928f43a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,6 +27,7 @@ AC_CHECK_FUNCS(posix_memalign)
AC_CHECK_FUNCS(gettimeofday)
AC_CHECK_FUNCS(sysconf)
AC_CHECK_FUNCS(lseek64)
+AC_CHECK_FUNCS(srand48_r)
SAVED_LIBS=$LIBS
AC_SEARCH_LIBS([pthread_create], [pthread])
# AC_SEARCH_LIBS adds libraries at the start of $LIBS so remove $SAVED_LIBS