aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDouglas Gilbert <dgilbert@interlog.com>2012-03-12 17:03:41 +0000
committerDouglas Gilbert <dgilbert@interlog.com>2012-03-12 17:03:41 +0000
commit60c487d370cfbfa7d91bc777eba4277c00536430 (patch)
tree86b621fcbe7cfb9bb7e263535dea7e19c1afad3f /configure.ac
parentaa38066befd415aafd0d138169184ded0a12cdf0 (diff)
downloadsg3_utils-60c487d370cfbfa7d91bc777eba4277c00536430.tar.gz
./configure: change --enable-no-linux-bsg to --disable-linuxbsg, add --disable-scsistrings to reduce utility size; report sdat_ovfl bit if set in sense
git-svn-id: https://svn.bingwo.ca/repos/sg3_utils/trunk@444 6180dd3e-e324-4e3e-922d-17de1ae2f315
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 60df2b2a..9cf8efc6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,14 +66,18 @@ AM_CONDITIONAL(OS_SOLARIS, [echo $host_os | grep '^solaris' > /dev/null])
AM_CONDITIONAL(OS_WIN32_MINGW, [echo $host_os | grep '^mingw' > /dev/null])
AM_CONDITIONAL(OS_WIN32_CYGWIN, [echo $host_os | grep '^cygwin' > /dev/null])
-AC_ARG_ENABLE([no-linux-bsg],
- AC_HELP_STRING([--enable-no-linux-bsg], [ignore linux bsg (sgv4) if present]),
- AC_DEFINE_UNQUOTED(IGNORE_LINUX_BSG, 1, [ignore linux bsg], )
-)
+AC_ARG_ENABLE([linuxbsg],
+ AC_HELP_STRING([--disable-linuxbsg], [ignore linux bsg (sgv4) if present]),
+ [AC_DEFINE_UNQUOTED(IGNORE_LINUX_BSG, 1, [ignore linux bsg], )], [])
AC_ARG_ENABLE([win32-spt-direct],
AC_HELP_STRING([--enable-win32-spt-direct], [enable Win32 SPT Direct]),
AC_DEFINE_UNQUOTED(WIN32_SPT_DIRECT, 1, [enable Win32 SPT Direct], )
)
+AC_ARG_ENABLE([scsistrings],
+ [AS_HELP_STRING([--disable-scsistrings],
+ [Disable full SCSI sense strings])],
+ [], [AC_DEFINE_UNQUOTED(SG_SCSI_STRINGS, 1, [full SCSI sense strings], )])
+
AC_OUTPUT(Makefile include/Makefile lib/Makefile src/Makefile doc/Makefile)