aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDouglas Gilbert <dgilbert@interlog.com>2019-01-11 06:11:25 +0000
committerDouglas Gilbert <dgilbert@interlog.com>2019-01-11 06:11:25 +0000
commit2433a22138f1b508c2765aa8499456cd6138a200 (patch)
treecf41a311a4230b908c6c14726bcfeae431bfdb48 /configure.ac
parent284fbfc7e0eb7b53b3ab7a9872aa1416685de785 (diff)
downloadsg3_utils-2433a22138f1b508c2765aa8499456cd6138a200.tar.gz
spc5r20 updates; fixes for FreeBSD 12.0 release
git-svn-id: https://svn.bingwo.ca/repos/sg3_utils/trunk@804 6180dd3e-e324-4e3e-922d-17de1ae2f315
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c9dbd4f4..8d641eb6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,10 +59,22 @@ check_for_linux_nvme_headers() {
]])
}
+check_for_linux_sg_v4_hdr() {
+ AC_EGREP_CPP(found,
+ [ # include <scsi/sg.h>
+ #ifdef SG_IOSUBMIT
+ found
+ #endif
+ ],
+ [AC_DEFINE_UNQUOTED(HAVE_LINUX_SG_V4_HDR, 1, [Have Linux sg v4 header]) ])
+
+}
+
case "${host}" in
*-*-android*)
AC_DEFINE_UNQUOTED(SG_LIB_ANDROID, 1, [sg3_utils on android])
AC_DEFINE_UNQUOTED(SG_LIB_LINUX, 1, [sg3_utils on linux])
+ check_for_linux_sg_v4_hdr
check_for_linux_nvme_headers;;
*-*-freebsd*|*-*-kfreebsd*-gnu*)
AC_DEFINE_UNQUOTED(SG_LIB_FREEBSD, 1, [sg3_utils on FreeBSD])
@@ -85,6 +97,7 @@ case "${host}" in
CFLAGS="$CFLAGS -D__USE_MINGW_ANSI_STDIO";;
*-*-linux-gnu* | *-*-linux* | *)
AC_DEFINE_UNQUOTED(SG_LIB_LINUX, 1, [sg3_utils on linux])
+ check_for_linux_sg_v4_hdr
check_for_linux_nvme_headers;;
esac