aboutsummaryrefslogtreecommitdiff
path: root/build_debian.sh
diff options
context:
space:
mode:
authorDouglas Gilbert <dgilbert@interlog.com>2007-06-27 03:24:23 +0000
committerDouglas Gilbert <dgilbert@interlog.com>2007-06-27 03:24:23 +0000
commit71e6e2d40657e63b9c20dc68f5e307639ef19c21 (patch)
tree18cab096bd20dcd67e51d1d741039fc85d3bad34 /build_debian.sh
parent88d420308cbb9cd9e58873ef726913690d5c91a4 (diff)
downloadsg3_utils-71e6e2d40657e63b9c20dc68f5e307639ef19c21.tar.gz
Load sg3_utils-1.21 into trunk/.
git-svn-id: https://svn.bingwo.ca/repos/sg3_utils/trunk@69 6180dd3e-e324-4e3e-922d-17de1ae2f315
Diffstat (limited to 'build_debian.sh')
-rwxr-xr-xbuild_debian.sh12
1 files changed, 12 insertions, 0 deletions
diff --git a/build_debian.sh b/build_debian.sh
new file mode 100755
index 00000000..7e815175
--- /dev/null
+++ b/build_debian.sh
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+echo "chmod +x debian/rules"
+chmod +x debian/rules
+
+# in some environments the '-rfakeroot' can cause a failure (e.g. when
+# building as root). If so, remove that argument from the following:
+echo "dpkg-buildpackage -b -rfakeroot"
+dpkg-buildpackage -b -rfakeroot
+
+# If the above succeeds then the ".deb" binary package is placed in the
+# parent directory.