summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml54
1 files changed, 54 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..336ee1e
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,54 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "siphasher"
+version = "1.0.1"
+authors = ["Frank Denis <github@pureftpd.org>"]
+description = "SipHash-2-4, SipHash-1-3 and 128-bit variants in pure Rust"
+homepage = "https://docs.rs/siphasher"
+documentation = "https://docs.rs/siphasher"
+readme = "README.md"
+keywords = [
+ "crypto",
+ "hash",
+ "siphash",
+]
+categories = [
+ "algorithms",
+ "cryptography",
+]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/jedisct1/rust-siphash"
+
+[profile.release]
+opt-level = 3
+lto = true
+panic = "abort"
+
+[dependencies.serde]
+version = "1.0"
+features = ["derive"]
+optional = true
+
+[dependencies.serde_json]
+version = "1.0"
+optional = true
+
+[features]
+default = ["std"]
+serde_no_std = ["serde/alloc"]
+serde_std = [
+ "std",
+ "serde/std",
+]
+std = []