aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorElie Kheirallah <khei@google.com>2023-04-28 21:56:11 +0000
committerAutomerger Merge Worker <android-build-automerger-merge-worker@system.gserviceaccount.com>2023-04-28 21:56:11 +0000
commitc443e836d5c56b83f7b2e87c0876bda29cb910c0 (patch)
treefe7bf0f76ec4187fddac28beafd69348da03ac13 /Cargo.toml
parentf827f0ac19518ff016b1ba880e25f7c6153bfe0d (diff)
parent37ff3bdb974637ca3792c918b2d644d05341a79d (diff)
downloadnamed-lock-c443e836d5c56b83f7b2e87c0876bda29cb910c0.tar.gz
Import named-lock am: 10099b967d am: a251f02d3c am: 2918246d30 am: 8c455a7a24 am: 37ff3bdb97
Original change: https://android-review.googlesource.com/c/platform/external/rust/crates/named-lock/+/2566511 Change-Id: I4d1bf4e96ebda466afab5ed1c08085254c1f8b6a Signed-off-by: Automerger Merge Worker <android-build-automerger-merge-worker@system.gserviceaccount.com>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml64
1 files changed, 64 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..e939ba4
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,64 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "named-lock"
+version = "0.3.0"
+authors = ["oblique <psyberbits@gmail.com>"]
+description = "Cross-platform implementation of cross-process named locks"
+readme = "README.md"
+keywords = [
+ "process",
+ "inter-process",
+ "cross-process",
+ "flock",
+ "CreateMutexW",
+]
+categories = ["os"]
+license = "MIT"
+repository = "https://github.com/oblique/named-lock"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.once_cell]
+version = "1.14.0"
+
+[dependencies.parking_lot]
+version = "0.12.1"
+
+[dependencies.thiserror]
+version = "1.0.35"
+
+[dev-dependencies.uuid]
+version = "1.1.2"
+features = ["v4"]
+
+[target."cfg(unix)".dependencies.libc]
+version = "0.2.132"
+
+[target."cfg(windows)".dependencies.widestring]
+version = "1.0.2"
+
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3.9"
+features = [
+ "handleapi",
+ "synchapi",
+ "winbase",
+ "winnt",
+ "winerror",
+]