summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJeff Vander Stoep <jeffv@google.com>2024-02-01 14:00:33 +0100
committerJeff Vander Stoep <jeffv@google.com>2024-02-01 14:00:34 +0100
commitfc66cf0e5917c166989360408d265133020fd510 (patch)
tree1d693e1cdf2ace296ebacf893aa7293deafa8a62 /Cargo.toml
parentf0eba62f7c65672e37713530fe123fe47fb93921 (diff)
downloadclap_complete-fc66cf0e5917c166989360408d265133020fd510.tar.gz
Upgrade clap_complete to 4.4.9simpleperf-release
This project was upgraded with external_updater. Usage: tools/external_updater/updater.sh update external/rust/crates/clap_complete For more info, check https://cs.android.com/android/platform/superproject/+/main:tools/external_updater/README.md Test: TreeHugger Change-Id: I8d6c3a390a21c87aed54d0714d84d92cce39db12
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml23
1 files changed, 18 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d71f151..89f121a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,7 +13,7 @@
edition = "2021"
rust-version = "1.70.0"
name = "clap_complete"
-version = "4.4.4"
+version = "4.4.9"
include = [
"build.rs",
"src/**/*",
@@ -36,7 +36,16 @@ license = "MIT OR Apache-2.0"
repository = "https://github.com/clap-rs/clap/tree/master/clap_complete"
[package.metadata.docs.rs]
-targets = ["x86_64-unknown-linux-gnu"]
+cargo-args = [
+ "-Zunstable-options",
+ "-Zrustdoc-scrape-examples",
+]
+features = ["unstable-doc"]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+ "--generate-link-to-definition",
+]
[[package.metadata.release.pre-release-replacements]]
file = "CHANGELOG.md"
@@ -122,10 +131,13 @@ features = [
default-features = false
[dev-dependencies.completest]
-version = "0.1.0"
+version = "0.4.0"
+
+[dev-dependencies.completest-pty]
+version = "0.5.0"
[dev-dependencies.snapbox]
-version = "0.4.13"
+version = "0.4.15"
features = [
"diff",
"path",
@@ -133,7 +145,7 @@ features = [
]
[dev-dependencies.trycmd]
-version = "0.14.18"
+version = "0.14.19"
features = [
"color-auto",
"diff",
@@ -144,6 +156,7 @@ default-features = false
[features]
debug = ["clap/debug"]
default = []
+unstable-doc = ["unstable-dynamic"]
unstable-dynamic = [
"dep:clap_lex",
"dep:shlex",