aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDanny Hermes <daniel.j.hermes@gmail.com>2015-04-13 10:06:18 -0700
committerDanny Hermes <daniel.j.hermes@gmail.com>2015-04-13 10:06:18 -0700
commit659869f19aec766f2b0187ecc95e414331892872 (patch)
treed41b038594803c3d17956d7548cb9939e0296837 /setup.py
parent0a6241c792f0c833f2f176292b0c7ea5623eabfd (diff)
downloadoauth2client-659869f19aec766f2b0187ecc95e414331892872.tar.gz
Adding system tests to make sure token exchange works as expected.
- Updates CONTRIBUTING.md to explain how to set-up and run these tests. - Requires a version of httplib2 that has not been released on PyPI yet in order to work on Python 3. - Simply creates 3 different token types (JSON key for svc. acct., P12 key for svc. acct., JSON key for user acct.) and then authorizes an httplib2.Http object to hit the USERINFO API.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 2e48f11..e0cf61e 100644
--- a/setup.py
+++ b/setup.py
@@ -35,7 +35,7 @@ packages = [
]
install_requires = [
- 'httplib2>=0.8',
+ 'httplib2>=0.9.1',
'pyasn1==0.1.7',
'pyasn1_modules==0.0.5',
'rsa==3.1.4',