aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPaul Ganssle <paul@ganssle.io>2018-03-11 10:54:48 -0400
committerPaul Ganssle <paul@ganssle.io>2018-03-11 11:26:39 -0400
commitf533b4adcc3965a84334eae5ec58148235cdf606 (patch)
tree63a4a009ded6d16e513c382cbcf727ca6019eaff /setup.py
parent66bc55d6d3bc4056d9d143cb1b344f89c0025edf (diff)
downloaddateutil-f533b4adcc3965a84334eae5ec58148235cdf606.tar.gz
Drop support for Python 3.2
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index b9e9c10..27d57ce 100644
--- a/setup.py
+++ b/setup.py
@@ -35,13 +35,13 @@ setup(name="python-dateutil",
maintainer="Paul Ganssle",
maintainer_email="dateutil@python.org",
url="https://dateutil.readthedocs.io",
- license="BSD 3-Clause",
+ license="Apache 2.0",
long_description="""
The dateutil module provides powerful extensions to the
datetime module available in the Python standard library.
""",
packages=PACKAGES,
- python_requires=">=2.7, !=3.0.*, !=3.1.*",
+ python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*",
package_data={"dateutil.zoneinfo": ["dateutil-zoneinfo.tar.gz"]},
zip_safe=True,
requires=["six"],
@@ -55,11 +55,11 @@ datetime module available in the Python standard library.
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Topic :: Software Development :: Libraries',
],
test_suite="dateutil.test",