aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorYaron de Leeuw <me@jarondl.net>2014-11-27 22:13:34 +0200
committerYaron de Leeuw <me@jarondl.net>2014-11-27 22:13:34 +0200
commitb759afd4f3a17ab9b3d9107f5d9cce350da51bee (patch)
treed89d8303427c3650395ff8d3b94cbbc6bcc64edc /setup.py
parent549dcc81b57d7a6469dab6f771a152633977f894 (diff)
downloaddateutil-b759afd4f3a17ab9b3d9107f5d9cce350da51bee.tar.gz
Package is now wheelable!
Changed the reading of the tar.gz file.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py12
1 files changed, 6 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index c7f089d..b50637c 100755
--- a/setup.py
+++ b/setup.py
@@ -20,9 +20,9 @@ VERSION = re.search('__version__ = "([^"]+)"',
setup(name="python-dateutil",
version = VERSION,
description = "Extensions to the standard Python datetime module",
- author = "Tomi Pievilaeinen",
- author_email = "tomi.pievilainen@iki.fi",
- url = "http://labix.org/python-dateutil",
+ author = "Yaron de Leeuw",
+ author_email = "me@jarondl.net",
+ url = "https://dateutil.readthedocs.org",
license = "Simplified BSD",
long_description =
"""\
@@ -30,9 +30,8 @@ The dateutil module provides powerful extensions to the
datetime module available in the Python standard library.
""",
packages = ["dateutil", "dateutil.zoneinfo"],
- package_data = {"": ["*.tar.gz"]},
- include_package_data = True,
- zip_safe = False,
+ package_data = {"dateutil.zoneinfo": ["dateutil-zoneinfo.tar.gz"]},
+ zip_safe = True,
requires = ["six"],
install_requires = ["six"], # XXX fix when packaging is sane again
classifiers = [
@@ -46,6 +45,7 @@ datetime module available in the Python standard library.
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
'Topic :: Software Development :: Libraries',
],
test_suite = "dateutil.test.test"