aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPaul Ganssle <paul@ganssle.io>2018-05-20 20:47:51 -0400
committerPaul Ganssle <paul@ganssle.io>2018-05-22 15:04:28 -0400
commit27708770c908e767a2901be91a8b8135b4163bff (patch)
tree9f067847ba794617825ea7e76a196e67b4ef1686 /setup.py
parent4ec670db17ff9bf9eabc1fc5eecf6815a55641a5 (diff)
downloaddateutil-27708770c908e767a2901be91a8b8135b4163bff.tar.gz
Make setup.py PEP8 compatible
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index b59bd63..7f4b86b 100644
--- a/setup.py
+++ b/setup.py
@@ -24,26 +24,27 @@ class Unsupported(TestCommand):
print("Running 'test' with setup.py is not supported. "
"Use 'pytest' or 'tox' to run the tests.")
+
###
# Load metadata
PACKAGES = find_packages(where='.', exclude=['dateutil.test'])
+
def README():
with io.open('README.rst', encoding='utf-8') as f:
readme_lines = f.readlines()
# The .. doctest directive is not supported by PyPA
lines_out = []
- doctest_line_found = False
for line in readme_lines:
if line.startswith('.. doctest'):
- doctest_line_found = True
lines_out.append('.. code-block:: python3\n')
else:
lines_out.append(line)
return ''.join(lines_out)
-README = README()
+README = README() # NOQA
+
setup(name="python-dateutil",
use_scm_version={