aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJeremy Maitin-Shepard <jbms@google.com>2022-10-03 14:19:34 -0700
committerFrank Barchard <fbarchard@chromium.org>2022-10-03 22:19:28 +0000
commitc365da9c6c3a75f6e5bb8779973da6e44988307e (patch)
treecbed39976bd63f53b6b7b215c3451f294ab87dda /CMakeLists.txt
parent4b93eb90ba26f5ec50c029c2e6a6698a264c8b11 (diff)
downloadlibyuv-c365da9c6c3a75f6e5bb8779973da6e44988307e.tar.gz
Use `find_package(JPEG)` in place of `include(FindJPEG)`
The former allows the package to be overridden with a local build by `FetchContent`. Also includes the fix to _MSC_VER conditions from: https://aomedia.googlesource.com/aom/+/refs/heads/main/third_party/libyuv/README.libaom Change-Id: I666e591becb3efaa7b5b68d27476319a2909b88e Reviewed-on: https://chromium-review.googlesource.com/c/libyuv/libyuv/+/3933570 Reviewed-by: Wan-Teh Chang <wtc@google.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d190507b..5f0306bc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,7 +42,7 @@ ADD_EXECUTABLE ( yuvconvert ${ly_base_dir}/util/yuvconvert.cc )
TARGET_LINK_LIBRARIES ( yuvconvert ${ly_lib_static} )
-INCLUDE ( FindJPEG )
+find_package ( JPEG )
if (JPEG_FOUND)
include_directories( ${JPEG_INCLUDE_DIR} )
target_link_libraries( yuvconvert ${JPEG_LIBRARY} )